2的n次方
计算2的n次方时间限制: 1000ms内存限制: 65536kB
描述
任意给定一个正整数N(N<=100),计算2的N次方的值。
输入
输入只有一个正整数N。
输出
输出2的N次方的值。
样例输入
5
样例输出
32
参考代码
import java.util.*;
public class Main {
public final static int SIZE = 30;
public static void main(String[] args) throws Exception {
scanner cin = new Scanner(System.in);
int n = cin.nextint();
int res[] = new int[SIZE + 1];
int i;
for(i = 0;i < SIZE;++ i){
res[i] = 0;
}
res[0] = 1;
while(n > 0){
for(i = 0;i < SIZE;++ i){
res[i] *= 2;
}
for(i = 0;i < SIZE;++ i){
if(res[i] > 9){
res[i + 1] += res[i] / 10;
res[i] %= 10;
}
}
n --;
}
boolean bl = false;
StringBuffer bf = new StringBuffer();
for(i = SIZE;i >= 0;-- i){
if(res[i] != 0 || bl){
bf.APPend(res[i]);
bl = true;
}
}
System.out.println(bf);
}
}
根据高位低位改进的代码:
/*
* title :power 2
* From :http://blog.csdn.net/binfeihan/article/details/6858655
* Author :Eric Zhou,binfeihan
* Email :[email protected]
*/
import java.io.BufferedReader;
import java.io.IOException;
import java.io.inputstreamreader;
public class Main {
public static void main(String[] args) throws IOException{
BufferedReader cin = new BufferedReader(new InputStreamReader(System.in));
int n = integer.parseInt(cin.readLine().trim());
System.out.println(my_power_2(n));
//System.out.println(Long.MAX_VALUE);
//System.out.println(Long.MIN_VALUE);
}
public static StringBuffer my_power_2(int N){
StringBuffer v = new StringBuffer("");
long num[] = new long[2];
num[1] = 1;
if(N > 62){
num[0] = 1;
num[0] = num[0]<<(N - 62);
num[1] = num[1]<<62;
String s = String.valueOf(num[1]);
int size = 30,i = 0,j = 0;
long n[] = new long[size + 1];
//System.out.println(num[0]+" "+s);
for(i = s.length() - 1;i >= 0;-- i){
n[j ++] = (long) (num[0] * (s.charAt(i) - '0'));
//System.out.println(n[j - 1]);
}
for(i = 0;i < size;++ i){
while(n[i] > 9){
n[i + 1] += n[i] / 10;
n[i] %= 10;
}
}
boolean bl = false;
for(i = size;i >= 0;-- i){
if(n[i] != 0 || bl){
v.append(n[i]);
bl = true;
}
}
}else{
num[1] = num[1] << N;
v.append(String.valueOf(num[1]));
}
return v;
}
}
相关阅读
微型计算机 本文是纯记录贴~对于一个新事物,总想问问为什么。在追求答案的道路上让人流连忘发,陶醉于其中。科学总是美好的,计算机科
关键路径: 从开始到结束得所有路径中,所话时间最长的一条为关键路径。关键路径上的任务的松弛时间(最多延迟执行的时间)为0。 最早开
github地址https://github.com/LMAX-Exchange/disruptorDisruptor是一个java的BlockingQueue,它的目的是在相同处理器的不同线程之
Audio Video Bridging(AVB)网络可调度流数目计算
缘起 在TTTech的一个Slide中看到了有关AVB性能的描述,Slide举例提到在默认配置下100Mbit的网络至多只能有13条流在一条网络链
cache电路 cache模型 cache算法 与cache相关的系统调用 0 cache简介 高速缓存(cache)是CPU内部用来加快数据访问的缓存技术。