morse code
Morse code
时间限制:1000 ms | 内存限制:65535 KB
难度:3
- 描述
-
前些时间看过一些TVB的电视剧,goshawk感觉 Morse code很神奇,它能够在懂这种规则的人之间进行信息传递。现在给你电码与字符对应的表格,让你将电码翻译成要进行传递的信息。
- 输入
- 每组测试数据一行,每行表示消息对应的电码,每个字母对应的电码用"/"隔开,文件以EOF结束。
- 输出
- 输出该段电码对应的信息,每组测试数据结果占一行。
- 样例输入
-
../._/__/._/.__./___/._../../_._././__/._/__/ ../._/__/.._./_.../../
- 样例输出
-
IAMAPOLICEMAM IAMFBI
import java.util.scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
String arr[] = { "._", "_...", "_._.", "_..", ".", ".._.", "__.",
"....", "..", ".___", "_._", "._..", "__", "_.", "___", ".__.",
"__._", "._.", "...", "_", ".._", "..._", ".__", "_.._",
"_.__", "__.." };
String string = "abcdefghijklmnopqrstuvwxyz";
while (scanner.hasNext()) {
String strArr[] = scanner.nextLine().split("/");
String show = "";
for (int i = 0; i < strArr.length; i++) {
for (int j = 0; j < arr.length; j++) {
if (strArr[i].equals(arr[j])) {
show += string.substring(j, j + 1);
break;
}
}
}
System.out.println(show);
}
}
}
文章最后发布于: 2017-09-17 14:15:17
相关阅读
关卡名称是对应codecombat(网易163)上面的关卡名。不到万不得已,请各位不要走这条捷径噢,毕竟思路比代码本身更重要。关卡代码为参考
1385. 幸运数字8 8是小九的幸运数字,小九想知道在1~n的数中有多少个数字含有8。 样例 Example1 Input: n = 20 Output: 2 Exp
中心对称数是指一个数字在旋转了 180 度之后看起来依旧相同的数字(或者上下颠倒地看)。 请写一个函数来判断该数字是否是中心对称
中文咋弄?酱紫json_encode($arr,JSON_UNESCAPED_UNICODE) 加个参数就好。
Okhttp3问题 Content type 'application/x-www-for
Content type ‘application/x-www-form-urlencoded;charset=UTF-8’ not supported。这种情况是缺少头部。需要添加UTF-8. 解决