必威体育Betway必威体育官网
当前位置:首页 > IT技术

玻璃珠

时间:2019-11-03 19:14:30来源:IT技术作者:seo实验室小编阅读:68次「手机版」
 

玻璃珠

题目名称:玻璃珠

题目链接:玻璃珠

描述

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace.

The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads.

The description of the necklace is a string A = a1a2 … am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion.

The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 … ana1 … ai-1 is lexicografically smaller than the string ajaj+1 … ana1 … aj-1. String a1a2 … an is lexicografically smaller than the string b1b2 … bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

输入

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a–z), where a < b … z.

输出

For each case, print exactly one line containing only one integer – number of the bead which is the first at the worst possible disjoining, i.e.\ such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

样例输入

4

helloworld

amandamanda

dontcallmebfu

aaabaaa

样例输出

10

11

6

5

题意如下:

给定一条字符串,首尾相连,求从哪里断开的字符串有最小的字典序

代码实现如下

#include<iOStream>
#include<string>
#include<cstring>
#include<cstdio>
using namespace std;
string s;
int n;

int solve()
{
	int i,j,l;
	i=0;
	j=1;
	int m=s.length();
	//这个while的意思是跳过字符串字符相同的位置
	while(i<m&&j<m){
		for(l=0;l<m;l++){
			if(s[(i+l)%m]!=s[(j+l)%m]){            
				break;
			}
		}
		if(l>m) break;
		if(s[(i+l)%m]>s[(j+l)%m]){
			i+=l+1;
		}else j+=l+1;
		if(i==j) j=i+1;;
	}
    return i<j?i:j;
}

int main()
{
     //关于feropen这个写法是我从码农场学来的,每次运行后可以直接从文本读取数据
//	freopen("in.txt","r",stdin);
	cin>>n;
	while(n--){
		cin>>s;
		cout<<solve()+1<<endl;
	}
	return 0;
} 

文章最后发布于: 2019-06-06 10:18:54

相关阅读

如何不花钱搞定1000个铁杆用户?

小编导读 : 2015年,金错刀频道会启动一个创业公益项目——《创业狠问答》。第一季就是“不花钱”系列。我被很多创业者问的最多的

论-100000乘以-100000

论-100000乘以-100000 #我真是闲的无聊,菜的一批,才会去论-10000乘以-100000,但我不知道为什么会爆?#计算完成之后类型转换#计算完成

北京监狱开通支付宝扫码存款:每次最多只能存1000元

A5创业网(公众号:iadmin5)1月15日报道,近日北京监狱与支付宝合作,上线了服刑人员综合账务管理系统,为服刑人员提供了狱内支付、家属存款

如何让营销QQ每天1000次邀请不受限制加好友?

营销QQ是拥有10万好友容量的一个企业版QQ,可以每天发出1000次好友邀请,但是很多用户在购买使用之后,发现并不能达到1000次邀请量,经常

浅谈setInterval(aa,1000)与setInterval(aa(),1000)的

一直有个疑惑,在定时器上调用某个方法时,加括号和不加括号有什么区别。今天做了个实验,发现,不加括号定时器会每秒执行一次,加了括号只

分享到:

栏目导航

推荐阅读

热门阅读