eight
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x
where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->
The letters in the previous row indicate which neighbor of the 'x' tile is swAPPed with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8
Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
Sample Input
2 3 4 1 5 x 7 6 8
Sample Output
ullddrurdllurdruldr
这道题,我学艺不精,没能掌握那么多的知识,我把自己会写的拿出来了,错了很多次,看网上的博客也看了,自己的境界没有那么多,紫书上面200页也看了,还是没学会。最后把我的代码给大家,思路就是一个广搜,重点是把这些操作步骤放在string里面,最后的时候输出。咋说呢,这道题肯定还会做的,等我学完搜索,我会补上它。今天发现这里的内存超限一定要控制他的数组开的范围,不要太大,不然你会坑惨了,呜呜呜,我就是一个例子。
#include<stdio.h>
#include<string.h>
#include<queue>
#include<math.h>
#include<string>
#include<map>
#include<algorithm>
using namespace std;
int step[4][2]={0,1,0,-1,1,0,-1,0};
struct node
{
string a;
int s[3][3];
int x,y;
};
map<int,int>u;
map<int,string>v;
void bfs()
{
queue<node>Q;
node st,en;
int i,j,k=1;
for(i=0;i<3;i++)
for(j=0;j<3;j++)
st.s[i][j]=i*3+j+1;
st.s[2][2]=0;
st.x=2;
st.y=2;
Q.push(st);
u[123456780]=1;
{
st=Q.front();
Q.pop();
for(i=0;i<4;i++)
{
en.x=st.x+step[i][0];
en.y=st.y+step[i][1];
if(en.x<0||en.x>=3||en.y<0||en.y>=3)
continue;
for(j=0;j<3;j++)
for(k=0;k<3;k++)
en.s[j][k]=st.s[j][k];
swap(en.s[st.x][st.y],en.s[en.x][en.y]);
int sum=1;
for(j=0;j<3;j++)
for(k=0;k<3;k++)
sum=sum*10+en.s[j][k];
if(u[sum]==1)
continue;
u[sum]=1;
if(i==0)
en.a=st.a+'l';
else if(i==1)
en.a=st.a+'r';
else if(i==2)
en.a=st.a+'u';
else if(i==3)
en.a=st.a+'d';
Q.push(en);
v[sum]=en.a;
}
}
}
int main()
{
bfs();
char s[500010];
while(gets(s))
{
int l=strlen(s);
int i,sum=1;
for(i=0;i<l;i++)
{
if(s[i]>='1'&&s[i]<='9')
sum=sum*10+s[i]-'0';
else if(s[i]=='x')
sum*=10;
}
if(u[sum]==0)
printf("unsolvable\n");
else
{
string st=v[sum];
for(i=st.length()-1;i>=0;i--)
printf("%c",st[i]);
printf("\n");
}
}
return 0;
}
相关阅读
JS中height、clientHeight、scrollHeight、offsetHeig
我们来实现test中的onclick事件 function justAtest() { var test= document.getElementById("test")
关于scrollHeight和scrollTop取值为0的问题
js:关于scrollHeight和scrollTop取值为0的问题 obj.offsetTop 指 obj 距离上方或上层控件的位置,整型,单位像素。 obj.offsetLeft
Android-0.Android Studio布局中layout_weight用法
Indicates how much of the extra space in the LinearLayout is allocated to the view associated with these LayoutParams.
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is construc
clientHeight、offsetHeight、scrollHeight、clientWi
网页可见区域宽:document.body.clientWidth 网页可见区域高:document.body.clientHeight 网页可见区域宽:document.body.offsetWid