必威体育Betway必威体育官网
当前位置:首页 > IT技术

Eight

时间:2019-08-22 02:14:21来源:IT技术作者:seo实验室小编阅读:54次「手机版」
 

eight

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 

 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 

 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swAPPed with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 

frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 

arrangement. 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 

x 4 6 

7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases. 

Sample Input

2  3  4  1  5  x  7  6  8

Sample Output

ullddrurdllurdruldr

题意:给出一列字符,如何变成123456789这种情况,输出变化方式。

思路:从最后的状态往前搜记录每种情况的变化方式。之后判断。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<math.h>
#include<string>
#include<map>
#include<algorithm>
using namespace std;
struct lou
{
    string a;
    int s[3][3];
    int x,y;
};
map<int,int>u;
map<int,string>v;
int r[4][2]={0,1,0,-1,1,0,-1,0};
void bfs()
{
    queue<lou>Q;
    lou p,q;
    int i,j,k;
    for(i=0;i<3;i++)
        for(j=0;j<3;j++)
            p.s[i][j]=i*3+j+1;
    p.s[2][2]=0;
    p.x=2;
    p.y=2;
    Q.push(p);
    u[123456780]=1;
    while(!Q.empty())
    {
        p=Q.front();
        Q.pop();
        for(i=0;i<4;i++)
        {
            q.x=p.x+r[i][0];
            q.y=p.y+r[i][1];
            if(q.x<0||q.x>=3||q.y<0||q.y>=3)
                continue;
            for(j=0;j<3;j++)
                for(k=0;k<3;k++)
                    q.s[j][k]=p.s[j][k];
            swap(q.s[p.x][p.y],q.s[q.x][q.y]);
            int sum=1;
            for(j=0;j<3;j++)
                for(k=0;k<3;k++)
                    sum=sum*10+q.s[j][k];
            if(u[sum]==1)
                continue;
            u[sum]=1;
            if(i==0)
                q.a=p.a+'l';
            else if(i==1)
                q.a=p.a+'r';
            else if(i==2)
                q.a=p.a+'u';
            else if(i==3)
                q.a=p.a+'d';
            Q.push(q);
            v[sum]=q.a;
        }
    }
}
int main()
{
    bfs();
    char s[30];
    while(gets(s))
    {
        int l=strlen(s);
        int i,sum=1;
        for(i=0;i<l;i++)
        {
            if(s[i]>='1'&&s[i]<='9')
                sum=sum*10+s[i]-'0';
            else if(s[i]=='x')
                sum*=10;
        }
        if(u[sum]==0)
            printf("unsolvable\n");
        else
        {
            string st=v[sum];
            for(i=st.length()-1;i>=0;i--)
                printf("%c",st[i]);
            printf("\n");
        }
    }
    return 0;
}

相关阅读

clientHeight、offsetHeight、scrollHeight、clientWi

网页可见区域宽:document.body.clientWidth 网页可见区域高:document.body.clientHeight 网页可见区域宽:document.body.offsetWid

真正的能理解CSS中的line-height,height与line-height

在最近的项目中,常常用到line-height,只是简单的理解为行高但并没有深层次的理解,致使不能达到信手拈来的感觉。在此做一下总结,一是

offsetTop,offsetHeight,clientHeight图解

动态的计算弹框距离外部元素的位置,即获取元素的offsetLeft、offsetTop、offsetWidth、offsetHeight,如果弹框的宽度(offsetWidth)+距

【带图】讲解offsetHeight、offsetLeft、clientWidth

1.偏移量元素的可见大小由其高度、宽度决定,包括所有内边距、滚动条和边框的大小(注意,不包括外边距)。offsetHeight:元素在垂直方向上

layout_weight用法以及注意事项

1、实现了水平方向50%平均分割 <LinearLayout android:orientation="horizontal"> <TextView android:layout_widt

分享到:

栏目导航

推荐阅读

热门阅读