必威体育Betway必威体育官网
当前位置:首页 > IT技术

HDU1239Calling Extraterrestrial Intelligence Again(打表)

时间:2019-07-25 20:10:00来源:IT技术作者:seo实验室小编阅读:64次「手机版」
 

extraterrestrial

calling extraterrestrial intelligence Again

Time limit: 2000/1000 MS (java/Others)Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6162Accepted Submission(s): 3254

Problem Description

A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974. The message consisted of 1679 bits and was meant to be translated to a rectangular picture with 23 * 73 pixels. Since both 23 and 73 are prime numbers, 23 * 73 is the unique possible size of the translated rectangular picture each edge of which is longer than 1 pixel. Of course, there was no guarantee that the receivers would try to translate the message to a rectangular picture. Even if they would, they might put the pixels into the rectangle incorrectly. The senders of the Arecibo message were optimistic.

We are planning a similar project. Your task in the project is to find the most suitable width and height of the translated rectangular picture. The term “most suitable” is defined as follows. An integer m greater than 4 is given. A positive fraction a / b less than or equal to 1 is also given. The area of the picture should not be greater than m. Both of the width and the height of the translated picture should be prime numbers. The ratio of the width to the height should not be less than a / b nor greater than 1. You should maximize the area of the picture under these constraints.

In other words, you will receive an integer m and a fraction a / b. It holds that m > 4 and 0 < a / b < 1. You should find the pair of prime numbers p, q such that pq <= m and a / b <= p / q <= 1, and furthermore, the product pq takes the maximum value among such pairs of two prime numbers. You should report p and q as the “most suitable” width and height of the translated picture.

Input

The input is a sequence of at most 2000 triplets of positive integers, delimited by a space character in between. Each line contains a single triplet. The sequence is followed by a triplet of zeros, 0 0 0, which indicated the end of the input and should not be treated as data to be processed.

The integers of each input triplet are the integer m, the numerator a, and the denominator b described above, in this order. You may assume 4 < m <= 100000 and 1 <= a <= b <= 1000.

Output

The output is a sequence of pairs of positive integers. The i-th output pair corresponds to the i-th input triplet. The integers of each output pair are the width p and the height q described above, in this order.

Each output line contains a single pair. A space character is put between the integers as a delimiter. No other characters should APPear in the output.

Sample Input

5 1 2

99999 999 999

1680 5 16

1970 1 1

2002 4 11

0 0 0

Sample Output

2 2

313 313

23 73

43 43

37 53

Source

Asia 2002, Kanazawa (Japan)

Recommend

Eddy|We have carefully selected several similar problems for you:12381240101610151241

题目大意:给定m,a,b;求素数p,q,满足p*q<=m,a/b<=p/q<=1,输出满足的p*q最大的p和q,

q,p<=2000 在2000范围内打素数表

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iOStream>
#define ll long long
using namespace std;
const int maxn = 2000+5;
int prime[maxn];
bool vis[maxn];
int m,a,b;
int ans =1;
void Prim()
{

    memset(vis,true,sizeof(vis));

    for(int i=2;i<maxn;i++)
    {
        if(vis[i]){
            prime[ans++]=i;
            for(int j=i+i;j<maxn;j+=i)
                vis[j]=false;
        }

    }
}
int main()
{
    Prim();
    while(scanf("%d %d %d",&m,&a,&b)!=EOF){
        if(m==0&&a==0&&b==0){
            break;
        }
        int Min = 0;
        int p=0,q=0;
        double s = (float)a/b;
        for(int i=1;i<ans;i++){
            if(prime[i]>m) break;

            for(int j=i;j<ans;j++){
                if(prime[i]*prime[j]>m) break;
                else {
                   // if(prime[i]==23&&prime[j]==73) printf("wolaiguo\n");
                    double f = (double)prime[i]/prime[j];
                    if(f>=s&&f<=1){
                        if(prime[i]*prime[j]>Min){
                            Min = prime[i]*prime[j];
                            p=prime[i];
                            q=prime[j];
               // if(prime[i]==23&&prime[j]==73) printf("wolaiguo2\n");
                        }
                    }
                }
            }
        }

        printf("%d %d\n",p,q);
    }
    return 0;
}

相关阅读

Mysql全文搜索之MATCH...AGAINST的用法介绍

前提:mysql只支持英文内容的全文索引,所以只考虑英文的全文搜索。假定数据表名为post,有三列:id、title、content。id是自增长序号,tit

分享到:

栏目导航

推荐阅读

热门阅读