period
Period
Time limit: 3000MS Memory Limit: 30000K
Total Submissions: 21636 Accepted: 10529
Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
Source
Southeastern Europe 2004
2406升级版…
KMP算法。
这道题考察的是KMP算法中next数组的应用,必须理解透next[]数组代表的含义才能通过它解决这道题。
思路是先构造出 next[] 数组,下标为 i,定义一个变量 j = i - next[i] 就是next数组下标和下标对应值的差,如果这个差能整除下标 i,即 i%j==0 ,则说明下标i之前的字符串(周期性字符串长度为 i)一定可以由一个前缀周期性的表示出来,这个前缀的长度为刚才求得的那个差,即 j,则这个前缀出现的次数为 i/j 。所以最后输出i和i/j即可。
举这道题的第二组输入样例为例:
其next[]数组为:
i 0 1 2 3 4 5 6 7 8 9 10 11
a[i] a a b a a b a a b a a b
next[i] -1 0 1 0 1 2 3 4 5 6 7 8
#include <iOStream>
#include <cstring>
#include <cstdio>
using namespace std;
const int M=1000005;
char a[M];
int p[M],n,j,t;
void work(){
for (int i=1;i<n;i++){
while (j>0 && a[j+1]!=a[i+1]) j=p[j];
if (a[j+1]==a[i+1]) j++;
p[i+1]=j;
if(j!=0 && (i+1)%(i-j+1)==0) printf("%d %d\n",i+1,(i+1)/(i-j+1));
}
}
int main(){
while(scanf("%d",&n)!=EOF){
if(n==0) break;
scanf("%s",a+1);p[1]=0;j=0;++t;
printf("Test case #%d\n",t);
work();printf("\n");
}
return 0;
}
相关阅读
pd.expanding()时间序列中min_periods到底怎么理解
DataFrame.expanding(min_periods=1, center=False, axis=0) return 的是a Window sub-classed for the particular operation