reward
Dandelion's uncle is a boss of a factory. As the Spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
Sample Input
2 1 1 2 2 2 1 2 2 1
Sample Output
1777 -1
#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
int n,m,num[10109],head[20109],in[20109],ans,k;
struct zz{
int to,next;
}qwe[20209];
topo()
{
queue<int> q;
int sum=0;
for(int i=1;i<=n;i++)
{
if(in[i]==0)
{
q.push(i);
}
}
while(!q.empty())
{
ans++;
k=q.front();
q.pop();
for(int j=head[k];j!=-1;j=qwe[j].next)
{
in[qwe[j].to]--;
if(in[qwe[j].to]==0)
{
q.push(qwe[j].to);
num[qwe[j].to]=num[k]+1;
}
}
}
for (int i=1;i<=n;i++) sum+=num[i];
if(ans<n) printf("-1\n");
else printf("%d\n",sum);
}
int main()
{
int a,b;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(head,-1,sizeof(head));
memset(in,0,sizeof(in));
for(int i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
qwe[i].to=a;
qwe[i].next=head[b];
head[b]=i;
in[a]++;
}
for(int i=1;i<=n;i++) num[i]=888;
ans=0;
topo();
}
return 0;
}
#include <stdio.h>
#include <string.h>
#include <queue>
#include <algorithm>
using namespace std;
struct zz
{
int to;int next;
}p[20200];
int in[10100];
int head[10100];
int num[10100];
void topo(int n)
{
queue<int>q;
int i,j,k;
int ans=0;
int sum=0;
for(i=1;i<=n;i++)
{
if(in[i]==0) q.push(i);//如果入度为0,就进入队列
}
while(!q.empty())
{
k=q.front();
q.pop();
ans++;
for(j=head[k];j!=-1;j=p[j].next)
{
in[p[j].to]--;
if(in[p[j].to]==0)
{
q.push(p[j].to);
num[p[j].to]=num[k]+1;
}
}
}
for(i=1;i<=n;i++)
sum+=num[i];
if(ans<n) printf("-1\n");
else printf("%d\n",sum);
}
int main()
{
int n,m,i,j,a,b;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(in ,0,sizeof(in));
memset(head,-1,sizeof(head));
for(i=1;i<=n;i++)
{
num[i]=888;
}
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);//由b指向a
p[i].to=a;//b->a,即a为终点
p[i].next=head[b];//表示与B同起点的上一条边的位置;
head[b]=i;//记录当前以B为起点的位置;
in[a]++;//记录A的入度;
}
topo(n);
}
return 0;
}