百度之星
题面:
度度熊有 NN 根木棒,每根木棒的长度为a_iai。
现在要挑选其中的三根,问能拼出的三角形的最大周长是多少。
如果不能拼成任何一个三角形,输出 -1−1。
Input
多组数据(不超过1010组),读到EOF结束。
对于每一组数据:
第一行一个数 NN 表示木棒数量。
第二行一共 NN 个数,描述每一根木棒的长度。
1 \leq N \leq 10001≤N≤1000
木棒长度都是不超过100000100000的正整数
Output
对于每一组数据,输出一个数表示答案。
Sample Input
3 1 1 100 7 1 9 9 90 2 2 4
Sample Output
-1 22
这个题比较简单:
#include<iOStream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#define pi acos(-1)
using namespace std;
typedef long long ll;
const int maxn=1e7+10;
const int INF=0x3f3f3f3f;
const double EPS = 1e-10;
inline int read(){
int ret=0,f=0;char ch=getchar();
while(ch>'9'||ch<'0') f^=ch=='-',ch=getchar();
while(ch<='9'&&ch>='0') ret=ret*10+ch-'0',ch=getchar();
return f?-ret:ret;
}
int n;
int a[1010];
int main()
{
ios::sync_with_stdio(false);
while(cin>>n){
for(int i=0;i<n;i++){
cin>>a[i];
}
bool Ok=false;
sort(a,a+n);
for(int i=n-1;i>1;i--){
if(a[i]<a[i-1]+a[i-2]){
Ok=true;
cout<<a[i]+a[i-1]+a[i-2];
break;
}
}
if(!Ok)cout<<-1<<endl;
}
return 0;
}
相关阅读
/* * 任意输入三角形三条整型边长 判断三角形的类型(普通 等腰 等边 直三角) */ #include <stdio.h> int main(void) { in
直接传入参数即可: public static void Triangle(int num) { for (int i = 1; i < num; i++) { for (int j = i; j <
求导运算 (sinx)′=cosx (\sin x)'=\cos x (sinx)′=cosx(cosx)′=sinx (\cos x)'=\sin x (cosx)′=sinx(
都说三角梨的网站素材好,谁知道啊,新开一见网店,想自己装修 ,不会,听朋友说三角梨的还不错,进来看一下,我现在的店面太难看了,http://shop
三角梨的 装修模板 为什么按照装修视频按照源码装上代码后 会 变成散乱的图片呢? 有知道如何操作的么 感激并酬谢!