必威体育Betway必威体育官网
当前位置:首页 > IT技术

Machine

时间:2019-08-05 18:42:07来源:IT技术作者:seo实验室小编阅读:62次「手机版」
 

machine

There is a machine with m(2≤m≤30)m(2≤m≤30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes. 

For any changed bulb, 

if it is red now it will be green; 

if it is green now it will be blue; 

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 

pushed n(1≤n<263)n(1≤n<263) times?

Input

There are multiple test cases. The first line of input contains an integer T(1≤T≤15)T(1≤T≤15) indicating the number of test cases. For each test case: 

The only line contains two integers m(2≤m≤30)m(2≤m≤30) and n(1≤n<263)n(1≤n<263).

Output

For each test case, output the colour of m bulbs from left to right. 

R indicates red. G indicates green. B indicates blue.

Sample Input

2
3 1
2 3

Sample Output

RRG
GR

题解:相当于把一个数转换为三进制,超出m位的舍去即可;

其中 0=R,1=G, 2=B;

注意n的值比较大,需要用 long long 格式

代码

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int t,a[30],m,i;
    long long n;
    scanf("%d",&t);
    while(t--){
        scanf("%d%lld",&m,&n);
        for(i=0;i<30;i++) a[i]=0;//重置数组
        i=m-1;
        while(n && i>=0){
            a[i]=n%3;
            n=n/3;
            i--;
        }
        for(i=0;i<m;i++)
            switch(a[i]){
                case 0: printf("R"); break;
                case 1: printf("G"); break;
                case 2: printf("B"); break;
            }
        printf("\n");
    }
    return 0;
}

相关阅读

Unity Cinemachine插件学习笔记,结合Timeline实现简单

1. 轨道设置如图 0和4重合,模拟一个闭环。的属性都是用来看的,没有实际影响。Looped如果选择了,就会将第一个点和最后一个点连接。 

分享到:

栏目导航

推荐阅读

热门阅读