必威体育Betway必威体育官网
当前位置:首页 > IT技术

ROADS

时间:2019-10-18 21:42:15来源:IT技术作者:seo实验室小编阅读:51次「手机版」
 

roads

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).

Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.

The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

  • S is the source city, 1 <= S <= N
  • D is the destination city, 1 <= D <= N
  • L is the road length, 1 <= L <= 100
  • T is the toll (expressed in the number of coins), 0 <= T <=100

notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.

If such path does not exist, only number -1 should be written to the output.

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

最近大家可能总是说贫穷限制了想象,这题也不例外,主人公想去N个城市玩,但是无可奈何想走近路,又没钱。于是只能在金钱允许的范围内,找到浏览N个城市的最短路。其实不知道为啥,一碰到最短路我就想广搜,结果广搜不适合这道题,还是看我深搜的代码吧,通俗易懂。

#include<stdio.h>

#include<string.h>

#include<algorithm>

using namespace std;

struct node

{

int a,b,c,d;

} list[10101];

int x[10000],y[10000],book[10000];

int n,m,p,minn,flag;

void cn(int start,int num,int sum)

{

if(num>p)

return;

if(sum>minn)

return ;

if(start==n&&num<=p)

{

if(sum<minn)

{

    flag=1;

    minn=sum;

}

return ;

}

for(int i=x[start]; i!=-1; i=y[i])

{

if(book[list[i].b]==0)

{

    book[list[i].b]=1;

    cn(list[i].b,num+list[i].d,sum+list[i].c);

    book[list[i].b]=0;

}

}

}

int main()

{

while(~scanf("%d%d%d",&p,&n,&m))

{

memset(x,-1,sizeof(x));

memset(y,-1,sizeof(y));

memset(book,0,sizeof(book));

for(int i=1; i<=m; i++)

{

    scanf("%d%d%d%d",&list[i].a,&list[i].b,&list[i].c,&list[i].d);

    y[i]=x[list[i].a];

    x[list[i].a]=i;

}

book[1]=1;

minn=0x3f3f3f3f;

flag=0;

cn(1,0,0);

if(flag==0)

    printf("-1\n");

else

    printf("%d\n",minn);

}

return 0;

}

相关阅读

分享到:

栏目导航

推荐阅读

热门阅读