必威体育Betway必威体育官网
当前位置:首页 > IT技术

Osu!

时间:2019-09-04 08:11:04来源:IT技术作者:seo实验室小编阅读:79次「手机版」
 

osu!

Description

Osu! is a very popular music game. Basically, it is a game about clicking. Some points will APPear on the screen at some time, and you have to click them at a correct time. 

Now, you want to write an algorithm to estimate how diffecult a game is. 

To simplify the things, in a game consisting of N points, point i will occur at time t i at place (x i, y i), and you should click it exactly at ti at (x i, y i). That means you should move your cursor from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 pided by the time between t i and t i+1. And the difficulty of a game is simply the difficulty of the most difficult jump in the game. 

Now, given a description of a game, please calculate its difficulty.

Input

The first line contains an integer T (T ≤ 10), denoting the number of the test cases. 

For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game.  Then N lines follow, the i-th line consisting of 3 space-separated integers, t i(0 ≤ t i < t i+1 ≤ 10 6), x i, and y i (0 ≤ x i, y i ≤ 10 6) as mentioned above.

Output

For each test case, output the answer in one line. 

Your answer will be considered correct if and only if its absolute or relative ERROR is less than 1e-9.

Sample Input


 

2

5

2 1 9

3 7 2

5 9 0

6 6 3

7 6 0

10

11 35 67

23 2 29

29 58 22

30 67 69

36 56 93

62 42 11

67 73 29

68 19 21

72 37 84

82 24 98

Sample Output


 

9.2195444573

54.5893762558

Hint

In memory of the best osu! player ever Cookiezi.

思路:求最大难度,难度为相邻两点的距离除以时间差。

AC代码

#include <iOStream>
#include <cstdio>
#include <algorithm>
#include <math.h>
using namespace std;
double a[10000];
double b[10000];
int ti[10000];
double dis(int i,int j)
{
    return sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        double ans=0;

        for(int i=0;i<n;i++)
        {
            scanf("%d%lf%lf",&ti[i],&a[i],&b[i]);
        }
        for(int i=1;i<n;i++)
        {
            ans=max(ans,(dis(i-1,i)/(ti[i]-ti[i-1])));
        }
        printf("%.10f\n",ans);
    }
    return 0;
}

相关阅读

jedis : NoSuchMethodError: org.springframework.uti

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'connectionFactory' defined in c

分享到:

栏目导航

推荐阅读

热门阅读