必威体育Betway必威体育官网
当前位置:首页 > IT技术

D - Decrease (Contestant ver.)(思维好题)

时间:2019-08-11 06:43:11来源:IT技术作者:seo实验室小编阅读:65次「手机版」
 

contestant

Problem statement

We have a sequence of length N consisting of non-negative integers. Consider performing the following operation on this sequence until the largest element in this sequence becomes N−1 or smaller.

Determine the largest element in the sequence (if there is more than one, choose one). Decrease the value of this element by N, and increase each of the other elements by 1.

It can be proved that the largest element in the sequence becomes N−1 or smaller after a finite number of operations.

You are given an integer K. Find an integer sequence ai such that the number of times we will perform the above operation is exactly K. It can be shown that there is always such a sequence under the constraints on input and output in this problem.

Constraints

0≤K≤50×1016

Input

Input is given from Standard Input in the following format:

K

Output

print a solution in the following format:

N

a1 a2 ... aN

Here, 2≤N≤50 and 0≤ai≤1016+1000 must hold.

Sample Input 1

0
Sample Output 1

4
3 3 3 3
Sample Input 2

1
Sample Output 2

3
1 0 3
Sample Input 3

2
Sample Output 3

2
2 2
The operation will be performed twice: [2, 2] -> [0, 3] -> [1, 1].

Sample Input 4

3
Sample Output 4

7
27 0 0 0 0 0 0
Sample Input 5

1234567894848
Sample Output 5

10
1000 193 256 777 0 1 1192 1234567891011 48 425

代码

#include <cstdio>
#include <cstring>
#include <iOStream>
using namespace std;
long long int a[51];
int main()
{
    long long int n;
    while(scanf("%lld",&n)==1)
    {
        memset(a,0,sizeof(a));
        for(long long int i=1;i<=50;i++)
            a[i]=49+n/50;                      //n/50就相当于50个数字每个数字都得要被减(n/50)次50还要加(n/50)次49(因为每个数被减去其他的数就要加一)
 
        long long int m=n%50;                  //多出来的要执行的操作次数;
        long long int j;
        for(int i=1;i<=50;i++) a[i]=a[i]-m;    //根据逆向思维,多出多少次,其他的数字就要减去多少个一;
        for(j=1;j<=m;j++)a[j]+=51;             //因为多出来m次,所以在m个数上加50;
 
        printf("50\n");
        for(int i=1;i<=50;i++)printf("%lld ",a[i]);
        printf("\n");
    }
    return 0;
}

相关阅读

三个方法:论构建产品游戏化思维

热火朝天的区块链经历了一个季度就淡然失色,朋友圈里做区块链的小伙伴们也一个一个都重新择业。用户对一个产品变心也是如此,光看各

高阶产品的必备思维模式:产业基本发展规律

想要成功晋升高阶产品?一个非常重要的技能就是要学会去思考产业的定位与布局。那么本文就来给大家介绍产品人成长必备的一个思维模

微博再创新媒体营销思维:“社交+”营销已成为一种新趋

自2016年以来,&ldquo;互联网+&rdquo;综合业务脱颖而出,并在许多行业取得了一些新的发展。互联网最直接的影响是改善营销方法。随着

【思维方式】如何判断一个产品是“好”产品?

很多场合下,产品经理都会被问到一个经典问题&#8211;什么样的产品才算是个好产品?今天我来尝试做下回答:个人觉得关于“好,坏”的判断

360董事长周鸿祎:互联网思维四大秘诀

目前,中央电视台《互联网时代》的热播遭遇360公司董事长周鸿祎新书《我的互联网方法论》的热卖。伴随着电视片第三集的播出,央视主

分享到:

栏目导航

推荐阅读

热门阅读