必威体育Betway必威体育官网
当前位置:首页 > IT技术

Nightmare

时间:2019-07-27 15:11:13来源:IT技术作者:seo实验室小编阅读:90次「手机版」
 

nightmare

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the Minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

1. We can assume the labyrinth is a 2 array.

2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.

3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.

4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.

5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.

6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.

There are five integers which indicate the different type of area in the labyrinth:

0: The area is a wall, Ignatius should not walk on it.

1: The area contains nothing, Ignatius can walk on it.

2: Ignatius' start position, Ignatius starts his escape from this position.

3: The exit of the labyrinth, Ignatius' target position.

4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4 
1 0 0 0 1 0 0 1 
1 4 1 0 1 1 0 1 
1 0 0 0 0 3 0 1 
1 1 4 1 1 1 1 1 

Sample Output

4
-1
13
#include<iOStream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<cmath>
#include<algorithm>
using namespace std;
int map[10][10];///地图
int n,m;
int dx[4]={0,0,1,-1},dy[4]={1,-1,0,0};///方向
struct node{
    int x;
    int y;
    int time,step;///时间和当前步数
};

void bfs(int x,int y){///广搜
    int i;
    
    queue<node>q;
    node now,next;
    now.step=0;
    now.time=6;
    now.x=x;
    now.y=y;
    q.push(now);
    while(!q.empty()){
        now=q.front();
        q.pop();
        for(i=0;i<4;i++){///上下左右都尝试前进
            next.x=now.x+dx[i];
            next.y=now.y+dy[i];
            next.time=now.time-1;
            next.step=now.step+1;
            if(next.x>=0&&next.x<n&&next.y>=0&&next.y<m&&map[next.x][next.y]!=0&&next.time>0){
                if(map[next.x][next.y]==3){///结束点,找到出口
                    printf("%d\n",next.step);
                    return ;
                }
                if(map[next.x][next.y]==4){///倒计时重置
                    next.time=6;
                    map[next.x][next.y]=0;
                }
                q.push(next);
            }
        }
    }
    printf("-1\n");///没找到出口就会到这来
    return ;
}


int main(){
    int i,j,t,sx,sy;
    cin>>t;    
    while(t--){
        cin>>n>>m;
        for(i=0;i<n;i++){
            for(j=0;j<m;j++){
                cin>>map[i][j];
                if(map[i][j]==2){
                    sx=i;
                    sy=j;
                }
            }
        }
        bfs(sx,sy);
    }
    return 0;
} 

相关阅读

nodejs之nightmare的使用--网络爬虫---论坛灌水

参考:https://www.cnblogs.com/xiaxuexiaoab/p/7297509.html nightmare是PhantomJS的高级封装,让你能够实现浏览器自动化任务。Pha

分享到:

栏目导航

推荐阅读

热门阅读