必威体育Betway必威体育官网
当前位置:首页 > IT技术

【POJ1383】BFS,迷宫,最长路

时间:2019-06-16 07:41:05来源:IT技术作者:seo实验室小编阅读:80次「手机版」
 

idealistic

Labyrinth

Time limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Submit Status

Description

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is pided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 

The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output

Maximum rope length is 0.
Maximum rope length is 8.

Hint

Huge input, scanf is recommended

If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc

题意:给你一个N*M的迷宫,迷宫里面有' # '和 ' . ' 两种字符,问你距离最远的两个' . '之间的距离。

思路:首先找到任意一个' . '的坐标(x1, y1),然后以该坐标为起点BFS整个迷宫找最长路,找到该坐标对应最长路的终点(x2, y2)。

再以(x2, y2)为起点BFS整个迷宫找最长路即可

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int n,m,sum,ex,ey;
char map[1010][1010];
int vis[1010][1010];
int d[4][2]={1,0,0,1,-1,0,0,-1};
bool judge(int x,int y)
{
	if(x>=0&&x<m&&y>=0&&y<n&&map[x][y]!='#')
	return true;
	return false;
}
struct node
{
	int x,y,step;
}now,next;
void bfs(int sx,int sy)
{
	queue<node>q;
	memset(vis,0,sizeof(vis));
	vis[sx][sy]=1;
	now.x=sx;
	now.y=sy;
	now.step=0;
	sum=0;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			next.x=now.x+d[i][0];
			next.y=now.y+d[i][1];
			if(judge(next.x,next.y))
			{
			next.step=now.step+1;
				if(vis[next.x][next.y]==0)
				{
					
					vis[next.x][next.y]=1;
					if(sum<next.step)
					{
						sum=next.step;
						ex=next.x;//记录中间端点值
						ey=next.y;
					}
					q.push(next);
				}
			}
		}
	}
	
}
using namespace std; 
int main()
{
	int t,sx,sy;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++)
		scanf("%s",&map[i]);
		for(int i=0;i<m;i++)
		{
			for(int j=0;j<n;j++)
			{
				if(map[i][j]=='.')
				{
				sx=i;
				sy=j;
				break;	
				}
			}
		}
		bfs(sx,sy);
		bfs(ex,ey);
		printf("Maximum rope length is %d.\n", sum);
	}
	return 0;
}

稍作修改的:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int n,m,sum,ex,ey;
char map[1010][1010];
int vis[1010][1010];
int d[4][2]={1,0,0,1,-1,0,0,-1};
bool judge(int x,int y)
{
	if(x>=0&&x<m&&y>=0&&y<n&&map[x][y]!='#'&&vis[x][y]==0)
	return true;
	return false;
}
struct node
{
	int x,y,step;
}now,next;
void bfs(int sx,int sy)
{
	queue<node>q;
	memset(vis,0,sizeof(vis));
	vis[sx][sy]=1;
	now.x=sx;
	now.y=sy;
	now.step=0;
	sum=0;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			next.x=now.x+d[i][0];
			next.y=now.y+d[i][1];
			if(judge(next.x,next.y))
			{
			       next.step=now.step+1;
					vis[next.x][next.y]=1;
					if(sum<next.step)
					{
						sum=next.step;
						ex=next.x;//记录中间的端点值 
						ey=next.y;
					}
					q.push(next);
			}
		}
	}
	
}
using namespace std; 
int main()
{
	int t,sx,sy;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++)
		scanf("%s",&map[i]);
		for(int i=0;i<m;i++)
		{
			for(int j=0;j<n;j++)
			{
				if(map[i][j]=='.')
				{
				sx=i;
				sy=j;
				break;	
				}
			}
		}
		bfs(sx,sy);
		bfs(ex,ey);
		printf("Maximum rope length is %d.\n", sum);
	}
	return 0;
}

相关阅读

逃离迷宫

给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可

邮件门的迷宫 希拉里邮件数据探索

摘要: 11月9日中午,不关心也不懂政治的我忽然非常感动,多少,我们在朋友圈的直播里见证了一个以一敌万的故事,这不是武侠小说,也不是好

室内迷宫创意策划

当代世界的许多年轻人对他们的生活有一些困惑,他们对未来的目标不够坚定。在从适应到适应的学习和工作过程中,我们可以采用新的模式

分享到:

栏目导航

推荐阅读

热门阅读