必威体育Betway必威体育官网
当前位置:首页 > IT技术

Romantic

时间:2019-07-30 07:12:08来源:IT技术作者:seo实验室小编阅读:51次「手机版」
 

romantic

Problem Description

The Sky is sprite.

The Birds is Fly in the Sky.

The Wind is Wonderful.

Blew throw the Trees

Trees are Shaking, Leaves are Falling.

Lovers Walk passing, and so are You.

................................Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!

Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

Input

The input contains multiple test cases.

Each case two nonnegative integer a,b (0<a, b<=2^31)

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.

Sample Input

77 51 10 44 34 79

Sample Output

2 -3

#include <iOStream>  
#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <string>  
#include <vector>  
#include <stack>  
#include <queue>  
#include <algorithm>  
using namespace std;

typedef long long LL;

LL exgcd(LL a, LL b, LL &x, LL &y) {
	if (b == 0) {
		x = 1;
		y = 0;
		return a;
	}
	LL ans = exgcd(b, a%b, x, y);
	LL t = x;
	x = y;
	y = t - a / b*y;
	return ans;
}

LL cal(LL a, LL b, LL c) {
	LL x, y;
	LL gcd = exgcd(a, b, x, y);
	if (c%gcd) {
		return -1;
	}
	x *= c / gcd;
	b /= gcd;
	b = abs(b);
	LL ans = x%b;
	if (ans <= 0)ans += b;
	return ans;
}

int main() {
	LL a, b, A, B, t;
	while (cin >> a >> b) {
		LL ans = cal(a, b, 1);
		if(ans==-1)	cout << "sorry\n";
		else cout << ans << " " << (1 - ans*a) / b << endl;
	}
}

sorry7 -3

相关阅读

分享到:

栏目导航

推荐阅读

热门阅读